Typeform surveys will not load on IE11

Incident Report for CIOPulse

Resolved

Typeform have released a fix and transactional (ticket) surveys that are running on Typeform are now working on IE11 again.
Posted Oct 01, 2021 - 07:59 AEST

Update

We are still pushing Typeform for an ETA on this issue. The best info we have is that they are 'hopeful' it will be resolved by the end of this week. We'll update this incident as soon as we have any further information.
Posted Sep 28, 2021 - 12:08 AEST

Update

Typeform have told us the fix to the IE11 bug may take a further week for them to fix.

If you are impacted, the quicker solution may be to start using our new survey engine for transactional surveys. The only change required is to edit a few characters in your survey invitation URL. Contact us at support@cio-pulse.com and we'll help you switch over.
Posted Sep 24, 2021 - 11:13 AEST

Update

Typeform developers are still working on a fix. We don't have an ETA yet.

If you have customers using IE11 and you're interested in switching to our new survey engine (which works with IE11), please reach out to us at support@cio-pulse.com and we'll help you.
Posted Sep 23, 2021 - 08:14 AEST

Identified

Typeform are aware of the error and working on a fix. They do not have an ETA yet.

If you have not already migrated to our new, in-house survey engine, you may want to change your survey URL now so that you are no longer using the Typeform engine for your transactional/ticket surveys. Please see here for details:
https://manual.cio-pulse.com/a/1198200-moving-to-our-new-survey-engine-23-may-to-28-november-2021
Posted Sep 22, 2021 - 10:37 AEST

Investigating

Surveys running on Typeform are no longer loading on IE11. An error page is displayed reporting, "Sorry, that didn't work".

If you are using our new, in-house survey engine this will not impact your transactional/ticket surveys. It will only impact the CCS form and Relationship/Project surveys.

This issue has been reported to Typeform and we are awaiting their response.

If you have not already migrated to our new, in-house survey engine, we strongly recommend that you change the survey URL in your survey invitation email template so that it points to our new, in-house survey engine. Please see here for details:
https://manual.cio-pulse.com/a/1198200-moving-to-our-new-survey-engine-23-may-to-28-november-2021

If you have any questions, or need help changing your survey URL, please contact us at support@cio-pulse.com.
Posted Sep 22, 2021 - 08:49 AEST
This incident affected: Customer Surveys & CSS Form.