Scheduled reports not issued. On-demand Survey Responses report failing

Incident Report for CIOPulse

Resolved

This incident has been resolved.
Posted May 24, 2021 - 16:48 AEST

Update

We are continuing to monitor for any further issues.
Posted May 24, 2021 - 13:41 AEST

Monitoring

We have deployed the multi-language font file we missed from this weekend's release. All reporting is now working.

We'll send a separate email to provide you with a workaround for getting CIOPulse to send out your Monday reports (Delighted Customers and Service Recovery).

This incident was caused because of a failure in our deployment mechansim. We should have detected this in our post-implementation testing, but didn't. We'll be taking a look at our release process to ensure we don't make this mistake again.

If you experience any further issues, please let us know at support@cio-pulse.com
Posted May 24, 2021 - 13:41 AEST

Update

We are continuing to work on a fix for this issue.
Posted May 24, 2021 - 13:10 AEST

Identified

Today's scheduled reports (Delighted Customer Report and Service Recovery Reports/Alerts) have not been issued. The on-demand Survey Responses report (survey-responses-nps) is failing with a "TCPDF ERROR: Could not include font definition file: arialuni" error.

This has been caused by a multi-language font file that was missing from the package we released on Sunday.

We'll provide another update in an hour, or when we've fixed the problem, whichever is sooner.
Posted May 24, 2021 - 13:09 AEST
This incident affected: Portal, Displays & Reports and SMS Alerting.