CIOPulse Incident - Surveys not loading on Microsoft Edge 44

Incident Report for CIOPulse

Resolved

This incident has been resolved
Posted Mar 21, 2021 - 11:14 AEDT

Monitoring

A fix has been implemented by Typeform and our surveys will once again run on legacy versions of Microsoft Edge.

We will monitor for 24 hours before marking this incident as resolved.

If you experience any more issues opening our surveys in Edge, please report them to us at support@cio-pulse.com.
Posted Mar 19, 2021 - 21:02 AEDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 19, 2021 - 21:00 AEDT

Identified

Typeform have identified the problem and are fixing it now. We're expecting this bug to be fixed by 7am on Saturday (AEDT).
Posted Mar 19, 2021 - 18:53 AEDT

Update

Typeform have acknowledged the problem and can replicate it, but they are still not able to share an ETA with us.

If you are impacted by this issue, and you'd like more information about it and the workarounds available, please contact us at support@cio-pulse.com.
Posted Mar 19, 2021 - 17:30 AEDT

Update

Typeform are telling us that their developers are still investigating this issue. They are not able to share an ETA with us.

If you are impacted by this issue, and you'd like more information about it and the workarounds available, please contact us at support@cio-pulse.com.
Posted Mar 18, 2021 - 20:01 AEDT

Update

Typeform are not responding to our requests for information about this incident. We are still pushing for a response. As a result, we're still unable to provide an ETA for this issue.

If you are impacted by this issue there are workarounds available. Please contact us at support@cio-pulse.com for more information.
Posted Mar 17, 2021 - 21:00 AEDT

Update

Typeform have escalated this issue internally but we still do not have an ETA.

This issue is currently preventing users of older versions of Edge from completing our surveys (the survey doesn't load). The survey is working on Edge versions from 79 onwards (released January 2020 onwards), but not on Edge versions 44 or before. Note that Edge versions jumped from 44 to 79 when Microsoft switched from their proprietary browser engine (EdgeHTML) to Chromium.

If you are impacted by this issue, and you'd like more information about it and the workarounds available, please contact us at support@cio-pulse.com.
Posted Mar 17, 2021 - 10:43 AEDT

Update

We are still waiting on an update from Typeform. We are chasing them for info.
Posted Mar 16, 2021 - 19:54 AEDT

Update

We are still waiting on a response from Typeform. Due to timezone differences, it is possible that we may not have an update for 8 hours.

Given the current uncertainty about the resolution timeframe for this incident, please get in touch with us at support@cio-pulse.com if you'd like us to outline some workaround options.
Posted Mar 16, 2021 - 14:31 AEDT

Investigating

We have received reports of our surveys not loading on Microsoft Edge 44 (the latest version of Edge is 89). The survey will load the page background and then the survey itself does not load - a loading icon spins indefinitely.

Our working theory is that Typeform (our survey engine provider) have released a change overnight that has broken Edge 44 support. Typeform are currently investigating.
Posted Mar 16, 2021 - 12:49 AEDT
This incident affected: Customer Surveys & CSS Form.